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Data Modeling Tools (Available only in Navicat Premium and Enterprise 

Version)  

Model is a powerful tool for creating and manipulating database models. Some of key 

features are listed here: 

 Create and manipulate a model graphically.  

 Reverse engineer a database/schema or table(s) to a model.  

 Forward engineer a model to a sql file or database/schema.  

 Create and edit table structures directly.  

Just simply click to open an object pane for Model. By using the object pane toolbar, you 

can create new, edit and delete the selected model. 

Create Model 

To create a new model 

 Select anywhere on the object pane.  

 Click the from the object pane toolbar. 

or  

 Control-click and select New Model to choose the popup menu.  

 Edit model properties in the Model Designer.  

To create a new model using reverse engineering 

 Open a database/schema.  

 Select the database/schema from the navigation pane or select the table(s) from the 

navigation pane/object pane.  

 Control-click the database/schema/table(s) and select Reverse Database to 

Model.../Reverse Table to Model from the popup menu.  

 Edit model properties in the Model Designer.  

To create a new model with the same properties as one of the existing models has 

 Select the model(s) for copying in the object pane.  

 Control-click and select the Duplicate Model from the popup menu.  

 The newly created model(s) will be named as "modelname_copy".  
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To create a new model with modification as one of the existing models 

 Select the model for modifying in the object pane.  

 Control-click and select the Design Model from the popup menu. 

or  

 Click the from the object pane toolbar.  

 Modify model properties in the Model Designer.  

 Click Save As.  

Edit Model  

To edit the existing model 

 Select the model for editing in the object pane.  

 Control-click and select the Design Model from the popup menu. 

or  

 Click the from the object pane toolbar.  

 Edit model properties in the Model Designer.  

To change the name of the model 

 Select the model for editing in the object pane.  

 Control-click and select the Rename from the popup menu.  

Delete Model 

To delete a model 

 Select the model for deleting in the object pane.  

 Control-click and select the Delete Model from the popup menu. 

or  

 Click the from the object pane toolbar.  

 Confirm deleting in the dialog window.  
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Achieve Model Information 

To achieve a model information 

 Select the model in the object pane.  

 Choose View -> Object Information in the main menu. 

or  

 Click the from the object pane toolbar.  
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Model Designer  

Model Designer is the basic Navicat tool for working with model. It allows you to create, 

edit, delete, print model and etc. 

 Model Tree Palette  

 Diagram Tree Palette  

 Model Diagram Palette  

 Properties Palette  

 History Palette  

 Printing Model  
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Model Tree Palette  

Model Tree holds all the tables in the model, including the tables used in each individual 

diagram. By default, it is located on the left sidebar. To show/hide the sidebar, simply click 

and choose Show Model Tree or Hide Model Tree. 

 

Create Table 

To create a new table 

 Click and choose Add Table.  

Edit Table 

To edit the existing table 

 Control-click the table in the model tree and select Design Table... from the popup 

menu.  

 Edit table properties and fields on the appropriate tabs.  

To change the name of the table 

 Select the table for editing in the model tree.  

 Control-click and select the Rename Table from the popup menu.  
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Delete Table 

To delete a table 

 Select the table for deleting in the model tree.  

 Control-click and select the Delete Table from the popup menu.  

 Confirm deleting in the dialog window.  
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Diagram Tree Palette  

Diagram Tree holds all the objects (tables, layers, notes, images and relations) added to 

the active diagram. By default, it is located on the left sidebar. To show/hide the sidebar, 

simply click and choose Show Model Tree or Hide Model Tree. 

 

Create Object 

To create a new object 

 Click and choose Add Table, Add Note, Add Image... or Add Layer.  

Edit Object 

To edit the existing table 

 Control-click the table in the diagram tree and select Design Table... from the popup 

menu.  

 Edit table properties and fields on the appropriate tabs.  

To change the name of the object 

 Select the object for editing in the diagram tree.  

 Control-click and select the Rename from the popup menu.  
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Delete Object 

To delete a table from the diagram 

 Select the table for deleting in the diagram tree.  

 Control-click and select the Delete -> From Diagram from the popup menu.  

 Confirm deleting in the dialog window.  

To delete a table from the model and diagram 

 Select the table for deleting in the diagram tree.  

 Control-click and select the Delete -> From Diagram and Model from the popup 

menu.  

 Confirm deleting in the dialog window.  

To delete a layer/note/image/relation from the diagram 

 Select the object for deleting in the diagram tree.  

 Control-click and select the Delete from the popup menu.  

 Confirm deleting in the dialog window.  
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Model Diagram Palette  

Model Diagram Palette is a canvas for you to design the diagram. Simply click the Add 

Diagram from the toolbar to create a new diagram. 

 Creating Tables  

 Creating Notes and Labels  

 Creating Images  

 Creating Layers  

 Creating Relations  

 Formatting Diagram  
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Creating Tables  

To create a new table, click the button from the diagram toolbar and click anywhere on the 

canvas. 

To add an existing table from the model tree to the diagram, simply drag and drop the table 

from model tree to the canvas. 

Note: If you control-click a field, you can choose to add, insert, delete, rename field and set 

the field as primary key. 

 

The popup menu options of the table object in canvas include: 

Design Table... 

Edit the table structure in a designer, e.g. fields, indexes, foreign keys, etc. 

Note: The tabs and options in the designer depend on the diagram database type you 

are chosen. For the settings of different tabs, see Database Object Management. 

Add Related Tables 

Add all related tables to the selected table. 
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Add Field 

Add fields to the existing table. 

Cut 

Remove the table from the diagram and put it on the clipboard. 

Copy 

Copy the table from the diagram to the clipboard. 

Paste 

Paste the content from the clipboard into the diagram. 

Select All Tables 

Select all the tables in the diagram. 

Delete 

Delete a table from the diagram or from both diagram and model. 

Rename 

Change the name of the table. 

Color 

Change the color of the table. 

Size to Fit 

Resize the table automatically to fit its contents. 

Bring to Front 

Bring table to the foreground. 

Send to Back 

Move table to the background. 
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Creating Notes and Labels  

Notes or Labels are typically used to help document the diagram design process. For 

example, to explain a grouping table objects. 

To create a new note or label, click the button from the diagram toolbar and click 

anywhere on the canvas. 

 

The popup menu options of the note object in canvas include: 

Edit Note 

Change the content of the note. 

Style 

Choose the style of the note: Note or Label. 

Cut 

Remove the note from the diagram and put it on the clipboard. 

Copy 

Copy the note from the diagram to the clipboard. 

Paste 

Paste the content from the clipboard into the diagram. 
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Select All Notes 

Select all the notes in the diagram. 

Delete 

Delete a note from the diagram. 

Color 

Change the color of the note. 

Size to Fit 

Resize the note automatically to fit its contents. 

Bring to Front 

Bring note to the foreground. 

Send to Back 

Move note to the background. 
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Creating Images  

To create a new image, click the button from the diagram toolbar and click anywhere on 

the canvas. 

 

The popup menu options of the image object in canvas include: 

Reset Size 

Reset the size of the image to its original size. 

Reset Aspect Ratio 

Maintain image original width to height ratio. 

Cut 

Remove the image from the diagram and put it on the clipboard. 

Copy 

Copy the image from the diagram to the clipboard. 

Paste 

Paste the content from the clipboard into the diagram. 

Select All Images 

Select all the images in the diagram. 
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Delete 

Delete a image from the diagram. 

Bring to Front 

Bring image to the foreground. 

Send to Back 

Move image to the background. 
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Creating Layers  

Layers are used to help organize objects (e.g. tables, notes, images, etc) on the canvas. You 

can add all related objects to the same layer. For example, you may choose to add all your 

sales related tables to one layer. 

To create a new layer, click the button from the diagram toolbar and click anywhere on 

the canvas. 

You can put any objects on top of the layer.  

 

The popup menu options of the layer object in canvas include: 

Cut 

Remove the layer from the diagram and put it on the clipboard. 

Copy 

Copy the layer from the diagram to the clipboard. 
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Paste 

Paste the content from the clipboard into the diagram. 

Select All Layers 

Select all the layers in the diagram. 

Delete 

Delete a layer from the diagram. 

Color 

Change the color of the layer. 

Size to Fit 

Resize the layer automatically to fit its contents. 

Bring to Front 

Bring layer to the foreground. 

Send to Back 

Move layer to the background. 
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Creating Relations  

To add a relation, click the button from the diagram toolbar and drag and drop a field from 

one table to another. 

 

The popup menu options of the relation object in canvas include: 

Design Relation... 

Edit the relation in a designer. 

Note: The options in the designer depend on the diagram database type you are chosen. 

For the settings, see Database Object Management. 

Cardinality on table_name1 

Set the cardinality on table_name1: None, One and Only One, Many, One or Many, Zero or 

One, Zero or Many. 
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Cardinality on table_name2 

Set the cardinality on table_name2: None, One and Only One, Many, One or Many, Zero or 

One, Zero or Many. 

Add Vertex 

Add a vertex on a relation connecter. 

Delete Vertex 

Delete a vertex on a relation connecter. 

Delete All Vertices 

Delete all vertices on a relation connecter. 

Paste 

Paste the content from the clipboard into the diagram. 

Select All Relations 

Select all the relations in the diagram. 

Delete from Diagram and Model 

Delete a relation from the diagram and model. 

Color 

Change the color of the relation. 
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Formatting Diagram  

Show Grid Lines 

To turn the grid on in the diagram canvas, choose Eidt -> Show Grid Lines from the main 

menu. 

Snap to Grid 

To align objects on the canvas with the grid, choose Eidt -> Snap to Grid from the main 

menu. 

Change Database Type 

To change the database type of the diagram, choose Edit -> Database and select the type 

from the main menu. Choose Generic if you do not decide the database type. 

Change Diagram Notation 

To change the notation of the diagram, choose Edit -> Diagram Notation and select the 

notation from the main menu. 

Default 

The default notation style used in Navicat. 

Simple 

A simple notation style. The table objects will only show the name. 

IDEF1X 

The ICAM DEFinition language information modeling method. 

UML 

Universal Modeling Language style. 

Crow's Foot 

Crow's Foot notation style. 

Black and White 

Change the color of the diagram to black and white. 

Change Diagram Dimensions 

To change the number of pages used in the diagram, choose Edit -> Diagram Dimension... 

from the main menu and set the Width and Height. 
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Apply Auto Layout 

To automatically arrange objects on the canvas, click Auto Layout from the toolbar. To 

change the Auto Layout, simply choose Edit -> Auto Layout With... from the main menu 

and set the options. 

Space Between Objects 

The distance between the objects in the diagram. 

Number of Trials 

The quality of the auto layout output. 

Auto Dimension 

Choose the suitable diagram dimension automatically. 

Tables resize to Fit 

Resize the table to fit its content automatically. 

Zoom In/Zoom Out 

To zoom in or zoom out the selected area of the diagram, adjust the slider of the Navigator. 

Same effect can be achieved with keyboard shortcuts:  

Zoom In: [Cmd-+] or [Cmd-Mousewheel up]  

Zoom out: [Cmd--] or [Cmd-Mousewheel down]  
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Properties Palette  

The Properties palette is used to display and edit the properties of diagram and its objects. 

Black & white 

Check this box to change the diagram color to black and white. 

Bold 

Check this box or press Cmd-B to bold the table or relation. 

Cardinality 

The relation cardinality of the table. 

Color 

The color of the object. 

Database 

The database type of the diagram. 

Font 

The font and font size of the note. 

Font Color 

The font color of the note. 

Name 

The name of the object. 

Notation 

The notation of the diagram. The value for this can be Default, Simple, IDEF1X, UML or 

Crow's Foot. 

Note Style 

The style of the note. The value for this can be Note or Label. 

Opacity 

The transparency of the image. 

Pages 

The width and height of the diagram (number of papers). 
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Position 

The number of pixels from the object to the left side (X) and the top (Y) of the canvas. 

Referenced 

The referenced (parent) table. 

Referencing 

The referencing (child) table. 

Show grid lines 

Check this box to turn the grid on in the diagram canvas. 

Size 

The width and height of the object. 

Snap to grid 

Check this box to align objects on the canvas with the grid. 

Table Font 

The font and font size of the table. 
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History Palette  

The History palette shows all the actions that you have taken. Simply double-click a action 

to restore that state. 
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Printing Model  

Page Setup 

Choose File -> Page Setup... to change paper size, orientation and margins. 

Print to a printer 

Simply click Print to send your diagram directly to the printer. You can set the printer 

option in the popup window. 

Print to a file (PDF/PNG/SVG) 

Choose File -> Print PDF.../Print PNG.../Print SVG... to create a PDF/PNG/SVG file of your 

diagram. 
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Export SQL  

Export SQL allows exporting table structures in model into a SQL file. 

 Select Export SQL from the toolbar.  

 Edit export properties on the appropriate tabs.  

 Click OK.  
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General Settings for Export SQL  

Export to File 

Set the output file name and location. 

Select tables to export 

You are allowed to choose your preferable tables in model you wish to export. 
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Advanced Settings for Export SQL  

Server Version 

Select server version for the SQL file. 

Include Schema Name (Available only for Oracle, PostgreSQL and SQL Server) 

Includes schema name entered below in file with this option is on. Otherwise, only table 

name is included in SQL statements. 

Include Drop SQL  

Includes drop table SQL statements in file with this option in on. 

Include Drop with CASCADE (Available only for MySQL, Oracle and 

PostgreSQL) 

Includes drop table SQL statements with cascade option in file with this option in on. 

Include Primary Keys  

Includes primary keys in file with this option is on. 

Include Indexes  

Includes indexes in file with this option is on. 

Include Foreign Keys  

Includes foreign keys in file with this option is on. 

Include Uniques (Available only for Oracle, PostgreSQL, SQLite and SQL Server) 

Includes uniques in file with this option is on. 

Include Charset (Available only for MySQL) 

Includes table and field character set in file with this option is on. 

Include Collation (Available only for SQLite and SQL Server) 

Includes table collation in file with this option is on. 
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Synchronize to Database  

Navicat allows you to compare and modify the table structures with detailed analytical 

process. In other words, Navicat compares tables between the target databases/schemas 

and the model and states the differential in structure.  

 Select Synchronize from the toolbar.  

 Edit synchronization properties on the General Settings tab.  

 Click Compare to generate a set of scripts which shows the differentiation between 

the databases/schemas and the model.  

 Select the scripts you want to run.  

 Click Run Queries.  
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General Settings for Synchronize to Database  

The following instruction guides you through the process of setting up a synchronization. 

Customize options according to your needs. 

Target 

Defines connection, database and schema for the target. 

Compare Options 

Compare primary keys 

Check this option if you want to compare table primary keys. 

Compare indexes  

Check this option if you want to compare indexes. 

Compare foreign keys 

Check this option if you want to compare table foreign keys. 

Compare character set (Available only for MySQL) 

Check this option if you want to compare character set of the tables. 

Compare uniques (Available only for Oracle, PostgreSQL, SQLite and SQL 

Server) 

Check this option if you want to compare uniques. 

Compare collation (Available only for SQLite and SQL Server) 

Check this option if you want to compare collation of the tables. 

Compare in case sensitive 

Check this option if you want to compare table identifier with case sensitive option. 

Execution Options 

SQL for objects to be created  

Check this option to include all related SQL statements if new objects will be created in 

the target database. 

SQL for objects to be changed  

Check this option to include all related SQL statements if objects will be changed in the 

target database. 
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SQL for objects to be dropped  

Check this option to include all related SQL statements if objects will be dropped from 

the target database. 

Compare after execution  

Compares tables after the synchronization is executed. 

Continue on error  

Ignores errors that are encountered during the synchronization process. 
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Synchronize to Database Results  

Source Objects/Target Objects 

The tree view shows the differentiation between the source database/schema and target 

database/schema after the computation of the structure synchronization, providing with the 

detailed SQL statements shown in the Result list.  

The red item represents the non-existence for the other database/schema.  

The blue item represents the existence for the other database/schema, but different 

definition detected. 

 

 

Result 

All the scripts are applied to the target database/schema and they are being checked in the 

Result list by default. To execute the checked scripts, press Run Queries.  

You can highlight multiple lines of scripts, and choose Invert Highlighted so as to toggle 

the selection status of scripts at one go.  
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To view the full SQL statements, simply click on the scripts.  
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Synchronize to Database Message Log  

The Message Log tab allows you to view the running process indicating success or failure. 

Example: 

(Run Queries) 

Query OK: ALTER TABLE 'clients' CHANGE COLUMN 'RecordID' 'RecordID' int(10) DEFAULT 

NULL first 
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Model Hints and Tips  

Navicat provides some useful hints to work on the model more effectively. 

Action Description  

Locate Object in 

Model Diagram 

Palette 

- Object selected in Diagram Tree will be highlighted in Model 

Diagram. 

- Double-click an object in Diagram Tree will jump to the 

corresponding object.  

Delete Table from 

Model Tree Palette 
- Select table in Model Diagram and press Shift + Delete. 

Open Table Designer - Double-click a table in Model Tree/Model Diagram. 

Add table from 

Navicat Main 

- Drag table from Navicat main window and drop to the Model 

Diagram. 

Get Table Structure 

(SQL Statement) 

- Select and copy the table in Model Diagram, and paste it to text 

editor, e.g. Notepad. 

Design Field without 

Table Designer 

- Select and click the table name and press Tab/Down Arrow to 

add/edit fields. 

 

Navicat will predict field types according to field names you 

entered.  

INTEGER/int/int4/NUMBER 

- suffix "id", "no" (if it is the first column, it will be predicted as a 

primary key) 

- suffix "num" 

- "qty", "number" 

- exactly "age", "count" 

 

DECIMAL(10,2)/decimal(10,2)/NUMBER/REAL/money 

- suffix "price", "cost", "salary" 

 

FLOAT/double/float8/NUMBER/REAL/float 

- "size", "height", "width", "length", "weight", "speed", "distance"  

 

DATE/datetime/date/TEXT/datetime2 

- "date", "time" 
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VARCHAR(255)/varchar(255)/VARCHAR2(255)/TEXT 

- other field names  

 

Enter * before the field name to recognize as primary key. e.g. 

*itemNo:int.  

Enter : between field name and field type to custom field type, 

e.g. itemName:varchar(255). 

Reorder Field 
- Select table in Model Diagram, then press and hold the Shift 

key. Use to drag the field to a desired location. 

Delete Field 
- Select table in Model Diagram, then press and hold the Shift 

key. Use to drag the desired field out of the table. 

Add Vertex to 

Relation 

- Select relation in Model Diagram, then press and hold the Shift 

key. Click on the relation to add vertex. 

Delete Vertex on 

Relation 

- Select relation in Model Diagram, then press and hold the Shift 

key. Click on the vertex. 

Delete Relation from 

Model 
- Select relation in Model Diagram and press Shift + Delete. 

Switch to Hand Mode - Press and hold the Space key, then move the diagram. 

 


