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SQL Previewer  

The SQL Preview tab shows the CREATE statement and necessary SQL statements of the 

database or schema object. 

For some database or schema objects, you can use the below dropdown list to show the SQL 

which will be run when pressing Save or Save As button. 
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Table Viewer  

Table Viewer displays the table data as a grid. Data can be displayed in three modes: 

Grid View, Form View and Text/Blob/BFile View. 

The toolbars of Table Viewer provides the following functions for managing data:  

 Commit 

Make permanent all changes performed in the transaction.  

Hint: The Commit button is visible only when Auto Commit is disabled under 

Option Settings. 

Note: Available only for Oracle and SQLite.  

 Rollback 

Undo work done in the current transaction.  

Hint: The Rollback button is visible only when Auto Commit is disabled under 

Option Settings. 

Note: Available only for Oracle and SQLite.  

 Import Data 

Import data from TXT, CSV, XML, DBF and more.  

 Export Data 

Export data to TXT, DBF, HTML, SQL, RTF and more.  

 Filter Data 

Allow you to filter records by creating and applying filter criteria for the data grid.  

 Edit TEXT/BLOB/BFile 

Allow you to view and edit the content of TEXT, BLOB and BFile fields.  

Note: Only Oracle supports BFile.  
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Data View  

This topic shows you how you can view and edit data from tables in the simplest and the most 

direct way. 

 Grid View  

 Form View  

 Text/Blob/BFile View  
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Grid View  

The grid view allows you to view, update, insert, or delete data in a table. The popup menu 

of the grid provides the following additional functions: set the field value as Null/Empty 

String, use current field value as a filter, format grid view, and more. 

 Using Navigation Bar  

 Editing Records  

 Sorting and Finding Records  

 Filtering Records  

 Manipulating Raw Data (Available only for MySQL, PostgreSQL and SQLite)  

 Formatting Table Grid  
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Using Navigation Bar  

Table Viewer provides a convenient way to navigate among the records/pages using 

Record/Page Navigation Bar buttons. All buttons are used to navigate left and right to the 

previous or the next records/pages. 

Record Objects Role 

 

First Record: allows moving to the first record. 

 

Previous Record: allows moving one record back (if 

there is one) from the current record. 

 

Next Record: allows moving one record ahead. 

 

Last Record: allows moving to the last record. 

 

Insert Record: used to enter a new record. At any 

point when you are working with your table in the 

grid view, click on this button to get a blank display 

for a record. 

 

Erase Record: used to delete an existing record. 

 

Edit Record: used to enter the edit mode. 

 

Update Record: used to apply the changes. 

 

Cancel Changes: used to removes all edits made to 

the current record. 

 

Refresh: used to refresh the table. 

 

Stop: used to stop when loading enormous data 

from server. 

Note: The SQL statement shows under the Record Objects indicate any statement has 

just been executed. 
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Page Objects Role 

 

First Page: allows moving to first page. 

 

Previous Page: allows moving to previous page. 

 

Next Page: allows moving to next page. 

 

Last Page: allows moving to last page. 

Record a of b in 

Page c 

Record/Page Indicator: displays the numbers 

representing the selected record and page. 

a. the selected record. 

b. number of records in the current page. 

c. the current page. 

 

Limit Record Setting: used to set number of records 

showing on each page.  
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Limit Record Setting  

Use the Limit Record Setting button to enter to the edit mode. 

Limit Records 

Check this option if you want to limit the number of records showed on each page. 

Otherwise, all records will be displayed in one single page. 

records per page 

Set the records per page value in the edit field. The number representing the number 

of records showed per page. 

Note: This setting mode will take effect on current table only. To adjust the global settings, 

see Options. 
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Editing Records  

The navigation bar allows you to switch the records quickly, insert, update or delete records. 

View data as a grid is most helpful for entering new records and editing old records in a table. 

Add Record 

To add a record 

 Make sure that your cursor is situated in the first blank cell on the table, then enter the 

desired data. If you are adding the new record into an existing table, just simply click 

on an existing record and click the from the navigation bar or press Ctrl+n to get 

a blank display for a record.  

 Watch the graphics symbol in the record selectors box just to the left of your record. 

It will change from the arrowhead , which indicates that it is the current record, to 

, which indicates that you are editing this record.  

 Just simply move to another record to save the record or click the from the 

navigation bar.  

Edit Record 

To edit a record 

 Select the record that you wish to edit by clicking in the specific field you want to 

change.  

 Type in the new data for that field.  

 Just simply move to another record, the new data will overwrite the previous data or 

click the from the navigation bar.  

Note: Close the table is another way to save the records. 

Delete Record 

To delete a record 

 Select the record that you wish to delete.  

 Just simply right-click and select Delete Record or click the from the navigation 

bar.  
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Editing Records with Special Handling  

To set Empty String for the cell, right-click the selected cell and select Set to Empty 

String. 

To set Null value for the cell, right-click the selected cell and select Set to NULL. 

To edit the text field record, just simply click Show Memo In Grid from the View toolbar. 

Note: Available only for MySQL, Oracle and PostgreSQL. 

 

Hint: To view/edit the text field record in an ease way, see Memo Editor. 

To view images in the grid, just simply click Show Image In Grid from the View toolbar. 

Note: Available only for MySQL, Oracle and PostgreSQL. 

 

Hint: To view/edit the image in an ease way, see Image Editor. 
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To edit a Date/Time record, just simply click or press Ctrl+Enter to open the editor for 

editing. 

Note: Available only for MySQL, Oracle and PostgreSQL. 

 Choose/enter the desired data. The editor used in cell is determined by the field type 

assigned to the column. 

 

Date Time DateTime / Timestamp 

 

 

 

To edit a Enum record, just simply choose the record from the drop-down list. 

Note: Available only for MySQL. 
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To edit a Set record, just simply click or press Ctrl+Enter to open the editor for editing. 

Note: Available only for MySQL. 

 Select the record(s) from the list. To remove the records, uncheck them in the same 

way.  

 

To view BFile content, just simply enables Preview BFile under the View menu. 

Note: Available only for Oracle. 

 

To generate UUID/GUID, right-click the selected cell and select Generate UUID. 

Note: Available only for PostgreSQL. 
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Editing Records with Foreign Key (Foreign Key Data Selection - Available 

only in Full Version)  

Foreign Key Data Selection is a useful tool for letting you to get the available value from 

the reference table in an easy way. It allows you to show additional record(s) from the 

reference table and search for a particular record(s). 

To include data to the record, just simply click or press Ctrl+Enter to open the editor for 

editing. 

 

 Just simply double-click to select the desired data.  

 

Hint: 1. By default, the number of records showed per page is 

100. To show all records, right-click anywhere on the 

grid and select Show All. To adjust the global 

settings, see Options.  

2. To refresh the record, right-click anywhere on the 

grid and select Refresh or press F5.  
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 Click to open a panel on the left for showing a list of column name(s). Just simply 

click to show the additional column. To remove the column(s), uncheck them in the 

same way.  

 

Hint: 1. To set column in ascending or descending mode, 

right-click anywhere on the column and select Sort 

-> Sort Ascending / Sort Descending. Remember 

to remove all sorting before applying on another 

column.  

2. To find for the text in the editor window, right-click 

anywhere on the grid and select Find or press Ctrl+F.  

 Enter a value into the edit box and click to filter for the particular record(s).  

 

Hint: To remove the filter results, right-click anywhere on the grid and select Show 

All.  
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Copying/Pasting Data from/into Navicat  

Data that being copied from Navicat goes into the windows clipboard with the fields delimited 

by tabs and the records delimited by carriage returns. It allows you to easily paste the 

clipboard contents into any application you want. Spreadsheet applications in general will 

notice the tab character between the fields and will neatly separate the clipboard data into 

rows and columns.  

Copy Data from Navicat 

To select data using Keyboard Shortcuts 

Ctrl+A 
Toggles the selection of all rows and columns in a 

data grid. 

Shift+Up Arrow 
Toggles the selection of rows as you move up in the 

data grid. 

Shift+Down 

Arrow 

Toggles the selection of rows in the data grid as you 

move down. 

 

To select data using Mouse Actions 

1. Highlighted the desired records by holding down the Ctrl key while clicking on each 

row.  

2. Highlighted range of records by clicking the first row you want to select and holding 

down the Shift key together with moving your cursor to the last row you wish to select.  

Note: After you have selected the desired records, just simply press Ctrl+C or right-click and 

select the Copy from the popup menu. 
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Paste Data into Navicat 

Data is copied into the clipboard will be arranged as below format: 

1. Data is arranged into rows and column.  

2. Rows and columns are delimited by carriage returns/tab respectively.  

3. Columns in the clipboard have the same sequence as the columns in the data grid you 

have selected.  

When pasting data into Navicat, you can replace the contents of current records and append 

the clipboard data into the table. To replace the contents of current records in a table, one 

must select the rows in the data grid whose contents must be replaced by the data in the 

clipboard. 

Note: Just simply press Ctrl+V or right-click and select the Paste from the popup menu. 

The paste action cannot be undone. 
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Sorting and Finding Records  

Sorting Records 

Server stores records in the order they were added to the table. Sorting in Navicat is used to 

temporarily rearrange records, so that you can view or update them in a different sequence. 

Click the column caption whose contents you want to sort by, right-click to select the Sort 

Ascending or Sort Descending mode from the popup menu or choose from the toolbar. 

Hint: Remember to remove all sorting before applying on another column. 

To sort by custom order of multi fields, right-click the grid to select the Custom Sort 

mode from the popup menu or choose from the toolbar. 
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Finding Records 

The Find Dialog is provided for quick searching for the text in the editor window. Just simply 

click Edit -> Find from the menu or press Ctrl+F and enter a search string. 

 

 

 

The search starts at the cursor's current position to the end of the file. There will not have 

differentiates when performing a uppercase or lowercase search. 

To find for the next text, just simply select Edit -> Find Next or press F3. 
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Filtering Records (Available only in Full Version)   

Use either of the following methods to filter the data in the grid: 

 Right-click a field and select the Filter from the popup menu to filter records by the 

current value of the selected column.  

 

 The Custom Filter Dialog is provided for quick building a simple filter. Just simply 

right-click a field and select the Filter -> Custom Filter from the popup menu. Use 

character '_' to represent any single symbol in the condition and use character '%' to 

represent any series of symbols in the condition.  

 You can also customize your filter in a more complicated way by right-clicking a field 

and selecting the Filter -> Filter Wizard from the popup menu or clicking the 

Filter Wizard from the toolbar. The Filter Wizard becomes visible at the top of grid, 

where you can see the active filtering condition and easily enable or disable it by 

clicking a check box at the left. 
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Manipulating Raw Data (Available only for MySQL, PostgreSQL and SQLite)  

Navicat normally recognize what user has input in grid as normal string, any special 

characters or functions would be processed as plain text (that is, its functionality would be 

skipped). 

Editing data in Raw Mode provides an ease and direct method to apply server built-in 

function. To access the Raw Mode function, just simply select View -> Raw Mode from the 

menu. 
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Formatting Table Grid  

Use the following methods to format the table grid: 

Move Columns 

1. Click on the column header and hold down the left mouse button.  

2. Move the pointer until a double black line appears in the desired location.  

3. Release the mouse and the column will move.  

 

Freeze Selected Column 

If there are many columns in the table and you want to freeze one or more columns to 

identify the record. Just simply right-click the column you want to freeze and select Freeze 

Selected Column or select View -> Freeze Selected Column from the menu. 

The frozen column(s) will move to the leftmost position in the table grid. This action will locks 

the frozen column(s), preventing them from being edited.  

To unfreeze the columns, just simply right-click anywhere on the table grid and select 

Unfreeze Columns or select View -> Unfreeze Columns from the menu. 

Set Display Format 

The Set Display Format Dialog is provided for you to customize format applied to exported 

data on the selected column. Just simply right-click the column you want to edit its format 

and select Set Display Format or select View -> Set Display Format from the menu. Edit 

the format style to adjust the result format in the way you need. For example: dd-mm-yyyy. 

Hint: This action applies on the selected column only. To adjust the global settings, see 

Options.  
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Set Column Width 

Click right border at top of column and drag either left or right. 

or 

Double-click right border at top of column to obtain the best fit for the column.  

or 

Right-click the column you want to set the column width with and select Set Column Width 

or select View -> Set Column Width from the menu. Specify width in the Set Column 

Width Dialog. The default value is 120. 

Hint: The result only applies on the selected column. To adjust the global settings, see 

Options.  

Set Row Height 

Right-click anywhere on the table grid and select Set Row Height or select View -> Set 

Row Height from the menu. Specify row height in the Set Row Height Dialog. The default 

value is 17. 

Hint: This action applies on the current table grid only. To adjust the global settings, see 

Options.  

Show/Hide Columns 

If there are many columns in the table and you want to hide some of them from the table grid. 

Just simply right-click anywhere on the table grid and select Show/Hide Columns or select 

View -> Show/Hide Columns from the menu. Select the columns that you would like to 

hide. 

The hidden column(s) will disappear from the table grid. 

To unhide the columns, just simply right-click anywhere on the table grid and select 

Show/Hide Columns or select View -> Show/Hide Columns from the menu. Select the 

columns that you would like to redisplay. 
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Show/Hide ROWID (Available only for Oracle and SQLite) 

If you want to display or hide the rowid (address) of every row, right-click anywhere on the 

table grid and select Show/Hide ROWID or select View -> Show/Hide ROWID from the 

menu. 

The column ROWID will be showed in the last column. 
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Form View (Available only in Full Version)   

The form view allows you to view, update, insert, or delete data as a form, which the current 

record is displayed: field name and its value. The popup menu of the form provides the 

following additional functions: set the field value as Null/Empty String, use current field 

value as a filter, format form view, and more. 

The navigation bar allows you to switch the records quickly, insert, update or delete records. 

 

Related topic: 

Sorting and Finding Records 

Filtering Records 

Manipulating Raw Data 

Formatting Table Grid 
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Text/Blob/BFile View  

Navicat provides Text/Blob/BFile Viewer and Editor to view and edit TEXT/BLOB/BFile fields 

content. The editor allows you to view, update, insert, or delete data in a table. 

Note: Oracle BFile fields cannot be edited. 

Click Memo, Hex and Image from the toolbar to activate the appropriate 

viewer/editor. 

 Viewing/Editing Text/BFile field as Memo  

 Viewing/Editing Text/Blob/BFile field as Hexadecimal  

 Viewing/Editing Blob/BFile field as Graphical Image  
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Viewing/Editing Text/BFile field as Memo  

The Memo panel allows you to edit data as a simple text. Use the button on the 

navigation bar to update the changed records to the table. 

Note: Oracle BFile fields cannot be edited. 
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Viewing/Editing Text/Blob/BFile field as Hexadecimal  

The Hex panel allows you to edit data in hexadecimal mode. Use the button on the 

navigation bar to update the changed records to the table. 

Note: Use the Insert key on the keyboard to switch between Insert and Overwrite modes 

Note: Oracle BFile fields cannot be edited. 
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Viewing/Editing Blob/BFile field as Graphical Image  

The Image panel allows you to show data as image. Use the Load, Save to disk and 

Clear button to load/remove the image from a file, or save the image to a table. 

Note: Oracle BFile fields cannot be edited. 

You can also right-click a Blob field type and save to disk. 
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Filter Wizard (Available only in Full Version)   

Filter Wizard allows you to facilitate creating and applying filter criteria that you specify for 

the table grid. Moreover, it allows you to save filter criteria as a profile for future use.  

Click Filter Wizard from the toolbar to activate the editor. 

 Adding New Filter Condition  

 Setting Filter Criteria  

 Setting Filter Operator  

 Setting Filter Criteria Values  

 Setting Filter Group  

 Applying Filter Conditions  

  



 

SQL Previewer & Table Viewer 31 

Adding New Filter Condition  

To add a new condition to the criteria, just simply click the <Click here to add> or 

right-click anywhere on the Filter Wizard and select the Add from the popup menu. 
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Setting Filter Criteria  

Suppose we need to select customers who come from US. This criteria is applied to the 

Country column. Click on the column box (next to the check box) and select Country item 

from the dropdown list which displaying all available column names. 
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Setting Filter Operator  

Click on the filter operator box (next to the column box) and select contains item from the 

dropdown list which displaying all available filter operators. 

Filter Operator Result 

is equal to <?> My_Field = 'your_value' 

is not equal to <?> My_Field <> 'your_value' 

is less than <?> My_Field < 'your_value' 

is less than or equal to <?> My_Field <= 'your_value' 

is greater than <?> My_Field > 'your_value' 

is greater than or equal to <?> My_Field >= 'your_value' 

contain <?> My_Field LIKE '%your_value%' 

does not contain <?> NOT (My_Field LIKE '%your_value%') 

begin with <?> My_Field LIKE 'your_value%' 

end with <?> My_Field LIKE '%your_value' 

is null My_Field IS NULL 

is not null My_Field IS NOT NULL 

is empty My_Field = '' 

is not empty My_Field <> '' 

is between <?> <?> 
((My_Field >= your_value1) and 

(My_Field <= your_value2)) 

is not between <?> <?> 
NOT ((My_Field >= your_value1) and 

(My_Field <= your_value2)) 

is in list <?> My_Field in ('aaa','bbb',...) 

is not in list <?> My_Field not in ('aaa','bbb',...) 

 



 

SQL Previewer & Table Viewer 34 

 

  



 

SQL Previewer & Table Viewer 35 

Setting Filter Criteria Values  

Click on the criteria values box (next to the filter operator box) to activate the appropriate 

editor and enter the criteria values (US). The editor used in criteria value boxes is 

determined by the editor type assigned to the corresponding column. 
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Setting Filter Group  

To implement a complex filter condition combining two simple conditions, just simply click on 

the <Click here to add> under the existing condition you have just defined. 

Suppose we need to select customers whose Company located in Suite 103, US. Apply 

Addr2 on column box, is equal to on filter operator box and Suite 103 on criteria values 

box under the existing condition. 

Setting filter group operator for the combine conditions, just simply click on the filter group 

operator box (by default, it specifies AND operator) to activate the appropriate editor. 
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Applying Filter Conditions  

Click the <Click here (ctrl+r) to apply> or press Ctrl+r to see the result of the filtering 

you made. 

Hint: You are allowed to save filter criteria to and load them from the registry for future use. 

Just simply right-click on the Filter Wizard and select Save Profile / Open Profile. 

 

 

 


