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Data Modeling Tools (Available only in Navicat Premium and Enterprise 

Version)  

Model is a powerful tool for creating and manipulating database models. Some of key 

features are listed here: 

 Create and manipulate a model graphically.  

 Reverse engineer a database/schema or table(s) to a model.  

 Forward engineer a model to a sql file or database/schema.  

 Create and edit table structures directly.  

Just simply click to open an object pane for Model. A right-click displays the popup menu 

or using the object pane toolbar, allowing you to create new, edit and delete the selected 

model. 

Create Model 

To create a new model 

 Select anywhere on the object pane.  

 Click the New Model from the object pane toolbar. 

or  

 Right-click and select New Model from the popup menu.  

 Edit model properties in the Model Designer.  

To create a new model using reverse engineering 

 Open a database/schema.  

 Select the database/schema from the navigation pane or select the table(s) from the 

navigation pane/object pane.  

 Right-click the database/schema/table(s) and select Reverse Database to 

Model.../Reverse Tables to Model... from the popup menu.  

 Edit model properties in the Model Designer.  
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To create a new model with the same properties as one of the existing models has 

 Select the model(s) for copying in the object pane.  

 Right-click and select the Copy from the popup menu.  

 Select anywhere on the object pane.  

 Right-click and select the Paste from the popup menu.  

 The newly created model(s) will be named as "modelname_copy".  

To create a new model with modification as one of the existing models 

 Select the model for modifying in the object pane.  

 Right-click and select the Design Model from the popup menu. 

or  

 Click the Design Model from the object pane toolbar.  

 Modify model properties in the Model Designer.  

 Click Save As.  

Edit Model  

To edit the existing model 

 Select the model for editing in the object pane.  

 Right-click and select the Design Model from the popup menu. 

or  

 Click the Design Model from the object pane toolbar.  

 Edit model properties in the Model Designer.  

To change the name of the model 

 Select the model for editing in the object pane.  

 Right-click and select the Rename from the popup menu.  

Delete Model 

To delete a model 

 Select the model for deleting in the object pane.  

 Right-click and select the Delete Model from the popup menu. 

or  

 Click the Delete Model from the object pane toolbar.  

 Confirm deleting in the dialog window.  
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Achieve Model Information 

To achieve a model information 

 Select the model in the object pane.  

 Right-click the selected model and choose Object Information from the popup menu. 

or  

 Choose View -> Object Information in the main menu.  

  



 

Data Modeling Tools 5 

Model Designer  

Model Designer is the basic Navicat tool for working with model. It allows you to create, 

edit, delete, print model and etc. 

 Model Tree Palette  

 Diagram Tree Palette  

 Model Diagram Palette  

 Properties Palette  

 History Palette  

 Model Preview and Print  
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Model Tree Palette  

Model Tree holds all the tables in the model, including the tables used in each individual 

diagram. By default, it is located on the left sidebar. To show/hide the sidebar, simply choose 

View -> Sidebar from the main menu. 

 

Create Table 

To create a new table 

 Select anywhere in the model tree.  

 Right-click and select New Table from the popup menu.  

Edit Table 

To edit the existing table 

 Right-click the table in the model tree and select Design Table from the popup menu.  

 Edit table properties and fields on the appropriate tabs.  

To change the name of the table 

 Select the table for editing in the model tree.  

 Right-click and select the Rename from the popup menu.  
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Delete Table 

To delete a table 

 Select the table for deleting in the model tree.  

 Right-click and select the Delete Table from the popup menu.  

 Confirm deleting in the dialog window.  
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Diagram Tree Palette  

Diagram Tree holds all the objects (tables, layers, notes, images and relations) added to 

the active diagram. By default, it is located on the left sidebar. To show/hide the sidebar, 

simply choose View -> Sidebar from the main menu. 

 

Create Object 

To create a new object 

 Select anywhere in the diagram tree.  

 Right-click and select New from the popup menu.  

 Choose the object.  

Edit Object 

To edit the existing table 

 Right-click the table in the diagram tree and select Design Table from the popup 

menu.  

 Edit table properties and fields on the appropriate tabs.  

To change the name of the object 

 Select the object for editing in the diagram tree.  

 Right-click and select the Rename from the popup menu.  
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Delete Object 

To delete a table from the diagram 

 Select the table for deleting in the diagram tree.  

 Right-click and select the Delete -> from Diagram from the popup menu.  

 Confirm deleting in the dialog window.  

To delete a table/relation from the model and diagram 

 Select the table/relation for deleting in the diagram tree.  

 Right-click and select the Delete -> from Diagram and Model from the popup 

menu.  

 Confirm deleting in the dialog window.  

To delete a layer/note/image from the diagram 

 Select the object for deleting in the diagram tree.  

 Right-click and select the Delete from the popup menu.  

 Confirm deleting in the dialog window.  
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Model Diagram Palette  

Model Diagram Palette is a canvas for you to design the diagram. Simply click the New 

Diagram from the toolbar to create a new diagram. 

 Creating Tables  

 Creating Layers  

 Creating Notes and Labels  

 Creating Images  

 Creating Relations  

 Formatting Diagram  
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Creating Tables  

To create a new table, click the button from the diagram toolbar and click anywhere on the 

canvas. 

To add an existing table from the model tree to the diagram, simply drag and drop the table 

from model tree to the canvas. 

Note: If you right-click a field, you can choose to add, insert, delete, rename field and set the 

field as primary key. 

 

The popup menu options of the table object in canvas include: 

Design Table 

Edit the table structure in a designer, e.g. fields, indexes, foreign keys, etc. 

Note: The tabs and options in the designer depend on the diagram database type you 

are chosen. For the settings of different tabs, see Database Object Management. 

Add Related Tables 

Add all related tables to the selected table. 

Add Field 

Add fields to the existing table. 
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Cut 

Remove the table from the diagram and put it on the clipboard. 

Copy 

Copy the table from the diagram to the clipboard. 

Paste 

Paste the content from the clipboard into the diagram. 

Select All Tables 

Select all the tables in the diagram. 

Delete 

Delete a table from the diagram or from both diagram and model. 

Rename 

Change the name of the table. 

Color 

Change the color of the table. 

Size to Fit 

Resize the table automatically to fit its contents. 

Bring to Front 

Bring table to the foreground. 

Send to Back 

Move table to the background. 
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Creating Layers  

Layers are used to help organize objects (e.g. tables, notes, images, etc) on the canvas. You 

can add all related objects to the same layer. For example, you may choose to add all your 

sales related tables to one layer. 

To create a new layer, click the button from the diagram toolbar and click anywhere on 

the canvas. 

You can put any objects on top of the layer.  

 

The popup menu options of the layer object in canvas include: 

Cut 

Remove the layer from the diagram and put it on the clipboard. 

Copy 

Copy the layer from the diagram to the clipboard. 

Paste 

Paste the content from the clipboard into the diagram. 
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Select All Layers 

Select all the layers in the diagram. 

Delete 

Delete a layer from the diagram. 

Color 

Change the color of the layer. 

Size to Fit 

Resize the layer automatically to fit its contents. 

Bring to Front 

Bring layer to the foreground. 

Send to Back 

Move layer to the background. 
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Creating Notes and Labels  

Notes or Labels are typically used to help document the diagram design process. For 

example, to explain a grouping table objects. 

To create a new note or label, click the button from the diagram toolbar and click 

anywhere on the canvas. 

 

The popup menu options of the note object in canvas include: 

Edit 

Change the content of the note. 

Style 

Choose the style of the note: Note or Label. 

Cut 

Remove the note from the diagram and put it on the clipboard. 

Copy 

Copy the note from the diagram to the clipboard. 

Paste 

Paste the content from the clipboard into the diagram. 
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Select All Notes 

Select all the notes in the diagram. 

Delete 

Delete a note from the diagram. 

Color 

Change the color of the note. 

Size to Fit 

Resize the note automatically to fit its contents. 

Bring to Front 

Bring note to the foreground. 

Send to Back 

Move note to the background. 
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Creating Images  

To create a new image, click the button from the diagram toolbar and click anywhere on 

the canvas. 

 

The popup menu options of the image object in canvas include: 

Reset Size 

Reset the size of the image to its original size. 

Reset Aspect Ratio 

Maintain image original width to height ratio. 

Cut 

Remove the image from the diagram and put it on the clipboard. 

Copy 

Copy the image from the diagram to the clipboard. 

Paste 

Paste the content from the clipboard into the diagram. 

Select All Images 

Select all the images in the diagram. 

Delete 

Delete a image from the diagram. 
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Bring to Front 

Bring image to the foreground. 

Send to Back 

Move image to the background. 
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Creating Relations  

To add a relation, click the button from the diagram toolbar and drag and drop a field 

from one table to another. 

 

The popup menu options of the relation object in canvas include: 

Design Relation 

Edit the relation in a designer. 

Note: The options in the designer depend on the diagram database type you are chosen. 

For the settings, see Database Object Management. 

Cardinality on table_name1 

Set the cardinality on table_name1: None, One and Only One, Many, One or Many, Zero or 

One, Zero or Many. 
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Cardinality on table_name2 

Set the cardinality on table_name2: None, One and Only One, Many, One or Many, Zero or 

One, Zero or Many. 

Add Vertex 

Add a vertex on a relation connecter. 

Delete Vertex 

Delete a vertex on a relation connecter. 

Delete All Vertices 

Delete all vertices on a relation connecter. 

Paste 

Paste the content from the clipboard into the diagram. 

Select All Relations 

Select all the relations in the diagram. 

Delete from Diagram and Model 

Delete a relation from the diagram and model. 

Color 

Change the color of the relation. 
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Formatting Diagram  

Show Grid 

To turn the grid on in the diagram canvas, choose View -> Show Grid from the main menu. 

Snap To Grid 

To align objects on the canvas with the grid, choose View -> Snap To Grid from the main 

menu. 

Change Database Type 

To change the database type of the diagram, choose Model -> Database and select the type 

from the main menu. Choose Generic if you do not decide the database type. 

Change Diagram Notation 

To change the notation of the diagram, choose Model -> Diagram Notation and select the 

notation from the main menu. 

Default 

The default notation style used in Navicat. 

Simple 

A simple notation style. The table objects will only show the name. 

Crow's Foot 

Crow's Foot notation style. 

IDEF1X 

The ICAM DEFinition language information modeling method. 

UML 

Universal Modeling Language style. 

Black and White 

Change the color of the diagram to black and white. 

Change Diagram Dimensions 

To change the number of pages used in the diagram, choose Model -> Diagram 

Dimensions... from the main menu and set the Width and Height. 
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Apply Auto Layout 

To automatically arrange objects on the canvas, click Auto Layout from the toolbar. To 

change the Auto Layout, simply choose Tools -> Auto Layout with... from the main menu 

and set the options. 

Auto Diagram Dimension 

Choose the suitable diagram dimension automatically. 

Auto Size Tables to Fit 

Resize the table to fit its content automatically. 

Quality 

The quality of the auto layout output. 

Object Distance 

The distance between the objects in the diagram. 

Zoom In/Zoom Out 

To zoom in or zoom out the selected area of the diagram, adjust the slider of the Navigator. 

If the Navigator is hidden, choose View -> Navigator from the main menu. Same effect can 

be achieved with keyboard shortcuts:  

Zoom In: [Ctrl++] or [Ctrl+Mousewheel up]  

Zoom out: [Ctrl+-] or [Ctrl+Mousewheel down]  
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Properties Palette  

The Properties palette is used to display and edit the properties of diagram and its objects. 

Black and White 

Check this box to change the diagram color to black and white. 

Bold 

Check this box or press Ctrl+B to bold the table or relation. 

Color 

The color of the object. 

Diagram Notation 

The notation of the diagram. The value for this can be Default, Simple, IDEF1X, UML or 

Crow's Foot. 

Font Bold 

Check this box to bold the note font. 

Font Color 

The font color of the note. 

Font Italic 

Check this box to apply an italic style to the note font. 

Font Name 

The font name of the note. 

Font Size 

The font size of the note. 

Height 

The height of the object. 

Height (pages) 

The height of the diagram (number of papers). 

Left 

The number of pixels from the object to the left side of the canvas. 
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Name 

The name of the object. 

Opacity 

The transparency of the image. The value for this can be between 0 to 100. Use 100 for 

opacity and 0 for transparent. 

Referenced Cardinality 

The relation cardinality of referenced (parent) table. 

Referencing Cardinality 

The relation cardinality of referencing (child) table. 

Style 

The style of the note. The value for this can be Note or Label. 

Table Font Name 

The font name of the tables. 

Table Font Size 

The font size of the tables. 

Top 

The number of pixels from the object to the top of the canvas. 

Width 

The width of the object. 

Width (pages) 

The width of the diagram (number of papers). 
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History Palette  

The History palette shows all the actions that you have taken. Simply double-click a action 

to restore that state. 
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Model Preview and Print  

Print Preview 

To preview the pages before printing, simply click the Print Preview button. The model 

can be printed to the printer or to various file formats. 

Page Setup 

Choose File -> Page Setup to change paper size, orientation and margins. 

Print to a printer 

Choose File -> Print to send your diagram directly to the printer. You can set the printer 

option in the popup window. 

Print to a file (PDF/PNG/SVG) 

Choose File -> Print As -> PDF/PNG/SVG to create a PDF/PNG/SVG file of your diagram. 
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Export SQL  

Export SQL allows exporting table structures in model into a SQL file. 

 Select Tools -> Export SQL... from the main menu.  

 Edit export properties on the appropriate tabs.  

 Click OK.  
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General Settings for Export SQL  

File 

Set the output file name and location. 

Tables 

You are allowed to choose your preferable tables in model you wish to export. 
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Advanced Settings for Export SQL  

Server Version 

Select server version for the SQL file. 

Include Schema (Available only for Oracle and PostgreSQL) 

Includes entered schema name in file with this option is on. Otherwise, only table name is 

included in SQL statements. 

Include Drop SQL  

Includes drop table SQL statements in file with this option in on. 

Include Drop with CASCADE (Available only for MySQL, Oracle and 

PostgreSQL) 

Includes drop table SQL statements with cascade option in file with this option in on. 

Include Primary Keys  

Includes primary keys in file with this option is on. 

Include Foreign Keys  

Includes foreign keys in file with this option is on. 

Include Uniques (Available only for Oracle, PostgreSQL and SQLite) 

Includes uniques in file with this option is on. 

Include indexes  

Includes indexes in file with this option is on. 

Include character set (Available only for MySQL) 

Includes table and field character set in file with this option is on. 

Include Collation (Available only for SQLite) 

Includes table collation in file with this option is on. 
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Synchronize to Database  

Navicat allows you to compare and modify the table structures with detailed analytical 

process. In other words, Navicat compares tables between the target databases/schemas 

and the model and states the differential in structure.  

 Select Tools -> Synchronize to Database... from the main menu.  

 Edit synchronization properties on the General tab.  

 Click Compare to generate a set of scripts which shows the differentiation between 

the databases/schemas and the model.  

 Select the scripts you want to run.  

 Click Run Query.  
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General Settings for Synchronize to Database  

The following instruction guides you through the process of setting up a synchronization. 

Customize options according to your needs. 

Target 

Defines connection, database and schema for the target. 

Compare Options 

Compare Identifier With Case Sensitive 

Check this option if you want to compare table identifier with case sensitive option. 

Compare Primary Keys 

Check this option if you want to compare table primary keys. 

Compare Foreign Keys 

Check this option if you want to compare table foreign keys. 

Compare Indexes  

Check this option if you want to compare indexes. 

Compare Character Set (Available only for MySQL) 

Check this option if you want to compare character set of the tables. 

Compare Uniques (Available only for Oracle, PostgreSQL and SQLite) 

Check this option if you want to compare uniques. 

Compare Collation (Available only for SQLite) 

Check this option if you want to compare collation of the tables. 

Execution Options 

SQL for objects to be created  

Check this option to include all related SQL statements if new objects will be created in 

the target database. 

SQL for objects to be changed  

Check this option to include all related SQL statements if objects will be changed in the 

target database. 
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SQL for objects to be dropped  

Check this option to include all related SQL statements if objects will be dropped from 

the target database. 

Continue on error  

Ignores errors that are encountered during the synchronization process. 
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Synchronize to Database Result  

Source Objects/Target Objects 

The tree view shows the differentiation between the source model and target 

database/schema after the computation of the structure synchronization, providing with the 

detailed SQL statements shown in the Queries for Modification list.  

The red item represents the non-existence for the other database/schema.  

The blue item represents the existence for the other database/schema, but different 

definition detected. 

 

 

Queries for Modification 

All the scripts are applied to the target database/schema and they are being unchecked in 

the Queries for Modification list by default. Just simply select the scripts you want to 

execute. 

You can highlight multiple lines of scripts, and then right-click to show the pop-up menu. 

Choose Copy can copy the selected queries to preferred editor. Choose Check Selected, 

Uncheck Selected, Check All or Uncheck All so as to perform selection/unselection of 

scripts at one go.  



 

Data Modeling Tools 34 

 

To view the full SQL statements you selected, right-click the Queries for Modification list 

and select Checked Scripts Detail. 

 

 

Compare after execution  

Compares tables after the synchronization is executed. 

Press Run Query to execute the selected query. 
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Synchronize to Database Message Log  

The Message Log tab allows you to view the running process indicating success or failure. 

Example: 

[Msg] Starting Synchronization 

[Msg] Target Server : MySQL 5.1 

[Msg] Target Database : report_sample 

[Msg] Executing - ALTER TABLE `report_sample`.`orders` ADD CONSTRAINT 

`fk_orders_customer_1` FOREIGN KEY (`CustNo`) REFERENCES `customer` 

(`CustNo`) 

[Msg] Completed 

[Msg] Synchronization Completed 
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Model Hints and Tips  

Navicat provides some useful hints to work on the model more effectively. 

Action Description  

Locate Object in 

Model Diagram 

Palette 

- Object selected in Diagram Tree will be highlighted in Model 

Diagram. 

- Double-click an object in Diagram Tree will jump to the 

corresponding object.  

Delete Table from 

Model Tree 

Palette 

- Select table in Model Diagram and press Shift + Delete. 

Open Table 

Designer 
- Double-click a table in Model Tree/Model Diagram. 

Add table from 

Navicat Main 

- Drag table from Navicat main window and drop to the Model 

Diagram. 

Get Table 

Structure (SQL 

Statement) 

- Select and copy the table in Model Diagram, and paste it to text 

editor, e.g. Notepad. 

Design Field 

without Table 

Designer 

- Select and click the table name and press Tab/Down Arrow to 

add/edit fields. 

 

Navicat will predict field types according to field names you 

entered.  

INTEGER/int/int4/NUMBER 

- suffix "id", "no" (if it is the first column, it will be predicted as a 

primary key) 

- suffix "num" 

- "qty", "number" 

- exactly "age", "count" 

 

DECIMAL(10,2)/decimal(10,2)/NUMBER/REAL 

- suffix "price", "cost", "salary" 

 

FLOAT/double/float8/NUMBER/REAL 

- "size", "height", "width", "length", "weight", "speed", 

"distance"  
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DATE/datetime/date/TEXT 

- "date", "time" 

 

VARCHAR(255)/varchar(255)/VARCHAR2(255)/TEXT 

- other field names  

 

Enter * before the field name to recognize as primary key. e.g. 

*itemNo:int. 

Enter : between field name and field type to custom field type, 

e.g. itemName:varchar(255). 

Reorder Field 
- Select table in Model Diagram, then press and hold the Shift 

key. Use to drag the field to a desired location. 

Delete Field 
- Select table in Model Diagram, then press and hold the Shift 

key. Use to drag the desired field out of the table. 

Add Vertex to 

Relation 

- Select relation in Model Diagram, then press and hold the Shift 

key. Click on the relation to add vertex. 

Delete Vertex on 

Relation 

- Select relation in Model Diagram, then press and hold the Shift 

key. Click on the vertex. 

Delete Relation 

from Model 
- Select relation in Model Diagram and press Shift + Delete. 

Switch to Hand 

Mode 
- Press and hold the Space key, then move the diagram. 

Select a Page in 

Print Preview 

- Press and hold the Shift key, then point to a page to show the 

page number. 

- Press and hold the Shift key, then click a page to jump to the 

corresponding page in Model Diagram. 

 


